BAG API v2 foutmelding icm Power Automate

Bij het via de http connector van Power Automate uitvoeren van het volgende BAG API v2 verzoek krijg ik de foutmelding dat de Accept-Crs header ontbreekt. Terwijl deze wel meegegeven wordt. Zie hier het verzoek:

"uri": https://api.bag.acceptatie.kadaster.nl/lvbag/individuelebevragingen/v2/adressenuitgebreid?postcode=2594AN&huisnummer=265&exacteMatch=true,
"method": "GET",
"headers":
    "X-Api-Key": "xxxxxxxxxxx",
    "Accept-Crs": "epsg:28992"

De response met foutmelding is:

“status”: 412,
“title”: “Gewenste coördinatenstelsel voor geometrie moet worden opgegeven.”,
“type”: “https://tools.ietf.org/html/rfc7232#section-4.2”,
“detail”: “Precondition failed.”,
“instance”: “https://api.bag.acceptatie.kadaster.nl/lvbag/individuelebevragingen/v2/adressenuitgebreid?postcode=2594AN&huisnummer=265&exacteMatch=true”,
“code”: “acceptCrsMissing”

Als ik requestcatcher.com gebruik, dan zie ik dat de “Accept-Crs” header inderdaad niet door Power Automate wordt doorgegeven. Ik ben benieuwd of iemand een oplossing kent voor dit probleem?

Ik vermoed dat “Accept-“ headers gevalideerd worden door Power Automate, en dat enkel standaard “Accept-“ headers worden geaccepteerd en doorgegeven. “Accept-Crs” valt dan af. Accepteert de BAG API misschien ook een andere syntax voor de “Accept-Crs” header i.p.v. “Accept-Crs”?

Ik hoop dat iemand mij met dit vraagstuk kan helpen?

Beste Bas12,
De BAG API Individuele Bevragingen kent geen andere syntax voor de Accept-Crs.

De tool ken ik zelf niet. Ik hoor wel van mijn collega’s dat op internet meer problemen te vinden zijn over deze tool icm Accept{-xxx}.

Bedankt voor je reply @NicoleKortoomsBAG,
Mocht iemand een oplossings(richting) weten, dan hoor ik het natuurlijk graag.

Bas,
Net ook eens geprobeerd:
Picture (Device Independent Bitmap) 1
en bij mij werkt het gewoon:
Picture (Device Independent Bitmap) 2

Hallo @SanderH,

Bedankt voor het checken! Hoopvol om te zien dat het wel werkt in Power Automate Desktop. Ik maak gebruik van de online versie van Power Automate en daar werkt het niet. Ik ga aan de hand van jouw info kijken of ik kan overstappen op de desktop versie.

Als iemand tips heeft om het ook werkend te krijgen in de online variant van Power Automate, dan hoor ik het natuurlijk graag.